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Intel® Play™ Computer Sound Morpher
Errors Related to InstallShield During Setup

Symptom(s):
Errors related to InstallShield during Setup
Error: "Setup failed to load installation engine - Error loading Type Library/DLL"
Error about missing file STDOLE32.TLB
Error: "Error extracting support files"
Error: "Error installing Ikernel.exe (0x any number)"
Error: "Access is denied"

Cause:
Setup initialization errors can be caused by a number of factors.

Solution:
From InstallShield's* support website at http://support.installshield.com/kb/default.asp, Document ID: Q105408:

   This link will take you off of the Intel Web site. Intel does not control the content of the destination Web Site.

Summary

If you are having a problem installing a product that uses InstallShield as their installation tool, and the steps below do not resolve your issue, you will need to contact the vendor of the software, as we cannot provide further support. Your vendor, who used InstallShield as an installation tool, created the product that you are trying to install. It is very likely that the error you are getting is related to how the vendor used our product and only the vendor would know which InstallShield product they used, which version and how they programmed it. Thank you for your understanding and patience.

This article applies to the following errors when trying to install an application that uses InstallShield:
  • Error extracting support files
  • Error installing Ikernel.exe (0x any number)
  • Access is denied
  • Error loading Type Library/DLL
Discussion

Detect Version
Different troubleshooting steps are necessary for different version of InstallShield. To check the version of InstallShield Professional that was used to create the setup, take the following steps:
  1. Right-click on the setup.exe.
  2. Select Properties.
  3. In the Properties dialog, select the tab labeled Version.
  4. Near the top there will be a filed labeled File Version. The number specified here will tell you approximately what version of InstallShield was used to create this install.
InstallShield 5.x and 3.x
If the version of InstallShield is less than 6.00, see article Q100198, HOWTO: Eliminating General Setup Initialization Errors.

InstallShield 6.x
If the version is 6.00 or greater, continue with the following steps.

Setup initialization errors can be caused by a number of factors. This is a non-exhaustive list of possible resolutions:
  1. Insufficient permissions on the machine. If you are using a Windows NT* or a Windows* 2000 machine, you need to have administrative permissions to run an InstallShield Professional 6.x setup. Make sure you have the correct permissions.

  2. If you just ran an InstallShield setup, the engine takes a few seconds at the end of the installation to clean up. During this time Ikernel.exe (the engine file) is running in memory from a previous process. That is why you are not allowed to launch another setup. Waiting a few seconds and running the setup again should resolve this.

  3. Check and make sure Ikernel.exe is not in memory. If it is, and no setup is running at the time, end that task and restart the system.

  4. Clean out the Temp directory.

  5. Delete the Program Files\Common Files\InstallShield\Engine folder and then rerun the setup.

  6. Reinstalling Internet Explorer (IE) 5.x can also repair a number of corrupted/missing core Windows files from your machine, so reinstalling IE 5.x and the NT service pack is also suggested.

  7. Another possibility is that you do not have sufficient COM permissions. For information on how to troubleshoot this, see article Q104986, INFO: Initialization Error Troubleshooting.

  8. The other potential cause is a missing Stdole.tlb file. This is a core Windows file and should exist on your machine. Make sure that if you get this file from another machine, the machine is running the same operation system as the machine you are trying to run the setup on.

  9. If you are trying to install to a Windows 98 machine, download and run Dcom98.exe from the following site: http://www.microsoft.com/com/dcom/dcom98/download.asp.

  10. Make sure that you are using the latest version of the InstallShield engine. To install the latest engine see article Q105097, INFO: Install the Latest Version of Ikernel.exe.

This applies to:
Intel® Play™ Computer Sound Morpher



Solution ID: CS-020112
Date Created: 21-Dec-2004
Last Modified: 29-Mar-2005
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